Getting a shell from Reverse TCP through Meterpreter – Digitalmunition




Home Forums Getting a shell from Reverse TCP through Meterpreter

This topic contains 1 reply, has 2 voices, and was last updated by  Linkk_93 1 month, 3 weeks ago.

  • Author
    Posts
  • #334958

    anonymous
    Participant

    Hi folks,

    I’m a cybersec student trying things on my personal computers at home. Today I tried to pop a shell on computer A with Kali as the attacker OS, running through a VM.

    The thing is that the computer A is hosting the VM

    Anyway, it worked flawlessly without disabling anything, got a shell and everything worked as intended.

    The problem is that it did not work at all when I tried to pop a shell with the same method on my laptop, that is on the same WI-FI.

    I know it is not realistic, but I even tried disabling my antivirus on the laptop but it still did not work.

    I had no problem to connect laptop A, that ha s a local IP of X.X. 1.22 to my listening meterpreter on X.X.63.128:4444, but for some reason my laptop that has a local IP adress of X.X.1.28 didnt succeed connecting to my open port.

    I have a few questions:

    What am I doing wrong, trying to connect to my laptop?

    Why didn’t I have to disable my antivirus on computer A for this to work on him?

    If you’ve read this far, thanks 🙂

    ​

    note: added X to IP adresses even though theyre local Ip because of the moderation rules of reddit

  • #334959

    Linkk_93

    your networks are not clear to me here. does X mean the same number? is it one broadcast domain?

    what I understood is :

    you have a laptop, that is the host of a vm. this host can connect to the vm, but external devices can not.

    my question:

    what network is the vm using? is it a local virtual adapter between the host and the vm? then how are other devices supposed to find the vm network?

You must be logged in to reply to this topic.