Gentoo Linux Security Advisory 202008-01 ≈ Packet Storm – Digitalmunition




Exploit/Advisories no-image-featured-image.png

Published on August 4th, 2020 📆 | 8457 Views ⚑

0

Gentoo Linux Security Advisory 202008-01 ≈ Packet Storm

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
Gentoo Linux Security Advisory GLSA 202008-01
– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –
https://security.gentoo.org/
– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

Severity: Normal
Title: Python: Multiple vulnerabilities
Date: August 02, 2020
Bugs: #728668, #732498
ID: 202008-01

– – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – – –

Synopsis
========

Multiple vulnerabilities have been found in Python, the worst of which
could result in a Denial of Service condition.

Background
==========

Python is an interpreted, interactive, object-oriented programming
language.

Affected packages
=================

——————————————————————-
Package / Vulnerable / Unaffected
——————————————————————-
1 dev-lang/python < 2.7.18-r1:2.7 >= 2.7.18-r1:2.7
< 3.6.11-r2:3.6 >= 3.6.11-r2:3.6
< 3.7.8-r2:3.7 >= 3.7.8-r2:3.7
< 3.8.4-r1:3.8 >= 3.8.4-r1:3.8

Description
===========

Multiple vulnerabilities have been discovered in Python. Please review
the CVE identifiers referenced below for details.

Impact
======

Please review the referenced CVE identifiers for details.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Python 2.7 users should upgrade to the latest version:

# emerge –sync
# emerge –ask –oneshot –verbose “>=dev-lang/python-2.7.18-r1”

All Python 3.6 users should upgrade to the latest version:

# emerge –sync
# emerge –ask –oneshot –verbose “>=dev-lang/python-3.6.11-r2”

All Python 3.7 users should upgrade to the latest version:

# emerge –sync
# emerge –ask –oneshot –verbose “>=dev-lang/python-3.7.8-r2”

All Python 3.8 users should upgrade to the latest version:

# emerge –sync
# emerge –ask –oneshot –verbose “>=dev-lang/python-3.8.4-r1”

References
==========

[ 1 ] CVE-2019-20907
https://nvd.nist.gov/vuln/detail/CVE-2019-20907
[ 2 ] CVE-2020-14422
https://nvd.nist.gov/vuln/detail/CVE-2020-14422

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

https://security.gentoo.org/glsa/202008-01

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users’ machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2020 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons – Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5

Source link

Tagged with:



Leave a Reply

Your email address will not be published. Required fields are marked *


loading...