Red Hat Security Advisory 2020-3383-01 ≈ Packet Storm – Digitalmunition




Exploit/Advisories no-image-featured-image.png

Published on August 10th, 2020 📆 | 2041 Views ⚑

0

Red Hat Security Advisory 2020-3383-01 ≈ Packet Storm

—–BEGIN PGP SIGNED MESSAGE—–
Hash: SHA256

====================================================================
Red Hat Security Advisory

Synopsis: Important: Red Hat JBoss Enterprise Application Platform 6.4 security update
Advisory ID: RHSA-2020:3383-01
Product: Red Hat JBoss Enterprise Application Platform
Advisory URL: https://access.redhat.com/errata/RHSA-2020:3383
Issue date: 2020-08-10
CVE Names: CVE-2020-13935
====================================================================
1. Summary:

An update is now available for Red Hat JBoss Enterprise Application
Platform 6.4 for Red Hat Enterprise Linux 5, 6, and 7.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 5 Server – noarch
Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6 Server – noarch
Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 7 Server – noarch

3. Description:

Red Hat JBoss Enterprise Application Platform is a platform for Java
applications based on the JBoss Application Server.

This asynchronous patch is an update for JBoss Enterprise Application
Platform 6.4 for Red Hat Enterprise Linux 5, 6, and 7. All users of Red Hat
JBoss Enterprise Application Platform 6.4 are advised to upgrade to this
updated package.

Security Fix(es):

* jbossweb: tomcat: multiple requests with invalid payload length in a
WebSocket frame could lead to DoS (CVE-2020-13935)

For more details about the security issue(s), including the impact, a CVSS
score, and other related information, see the CVE page(s) listed in the
References section.

4. Solution:

Before applying this update, ensure all previously released errata relevant
to your system have been applied. The JBoss server process must be
restarted for the update to take effect.

For details about how to apply this update, see:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

1857024 – CVE-2020-13935 tomcat: multiple requests with invalid payload length in a WebSocket frame could lead to DoS

6. Package List:

Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 5 Server:

Source:
jbossweb-7.5.31-2.Final_redhat_2.1.ep6.el5.src.rpm

noarch:
jbossweb-7.5.31-2.Final_redhat_2.1.ep6.el5.noarch.rpm

Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6 Server:

Source:
jbossweb-7.5.31-2.Final_redhat_2.1.ep6.el6.src.rpm

noarch:
jbossweb-7.5.31-2.Final_redhat_2.1.ep6.el6.noarch.rpm

Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 7 Server:

Source:
jbossweb-7.5.31-2.Final_redhat_2.1.ep6.el7.src.rpm

noarch:
jbossweb-7.5.31-2.Final_redhat_2.1.ep6.el7.noarch.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2020-13935
https://access.redhat.com/security/updates/classification/#important
https://access.redhat.com/documentation/en-us/red_hat_jboss_enterprise_application_platform/6.4/

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2020 Red Hat, Inc.
—–BEGIN PGP SIGNATURE—–
Version: GnuPG v1

iQIVAwUBXzExNNzjgjWX9erEAQj3ew/+O/vMhGMZzyHPbAkqwhxPIDi1v+DMOkcI
XKutCopzBz2R45IaxHnixlFhi00fVsXck+4Cp1b47hCwG6jK95d0onN1tNQ7mP93
+nT8lpNXADHCjMW8FfNm+TQ1hJ8n2cEa1zk1TmsvR1c3Xs5C4J1J7KUSXA1XgxZk
o7sLR9MN4C/KSZ+g0kjKKzWClsFxpYuWSrJaKQVPIanT838Hno3xXiiQl/hLV6+e
01RoTAAkUNdWKa0GnlE5uumjcapRBUmKB/T1u1e6YPNyY9cQ1lxRFZnkgrZGgK25
mr35tFS0KXzSAaexdaz/2ZNAC41Pb+5hA7Rla+ERnnyr7Pj+wuLD0gKNf7zZ933P
fvn/AG376/YJ75LlW64qHJ2NbKSu7hT5nwYVKy6VLKc7fnw2hpjFEj+iXcGJP3Cq
SzvVt0q5hhRWvYcWbMPh9wRExG1gZdZ8bMuq6SgI4UlsQpOasYRHEMBbdWUkV7on
WAd2QzGT6LK4lGTUw/of1FYWFZ9WbeEh8qOp0Ze3lrMDoM4vawWmTZ8T5Tf6Reu2
IRnO66U02HhDu3ai083o653lwVzK3HcFQd5HnLGIHTOVv9FFSBtc5htsuVGdq3J4
dhIhE4GveHVvbJpnAh1n4OxqRM6HAKEp7NCE/YhK9H6otYEqQ13OOmjEJLlLYrXQ
6tJPkB5hwGg=ZvRp
—–END PGP SIGNATURE—–


RHSA-announce mailing list
[email protected]
https://www.redhat.com/mailman/listinfo/rhsa-announce

Source link

Tagged with:



Leave a Reply

Your email address will not be published. Required fields are marked *


loading...