Red Hat Security Advisory 2020-3475-01 ≈ Packet Storm – Digitalmunition




Exploit/Advisories no-image-featured-image.png

Published on August 18th, 2020 📆 | 3235 Views ⚑

0

Red Hat Security Advisory 2020-3475-01 ≈ Packet Storm

—–BEGIN PGP SIGNED MESSAGE—–
Hash: SHA256

=====================================================================
Red Hat Security Advisory

Synopsis: Important: bind security update
Advisory ID: RHSA-2020:3475-01
Product: Red Hat Enterprise Linux
Advisory URL: https://access.redhat.com/errata/RHSA-2020:3475
Issue date: 2020-08-18
CVE Names: CVE-2020-8616 CVE-2020-8617
=====================================================================

1. Summary:

An update for bind is now available for Red Hat Enterprise Linux 7.6
Extended Update Support.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux ComputeNode EUS (v. 7.6) – noarch, x86_64
Red Hat Enterprise Linux ComputeNode Optional EUS (v. 7.6) – x86_64
Red Hat Enterprise Linux Server EUS (v. 7.6) – noarch, ppc64, ppc64le, s390x, x86_64
Red Hat Enterprise Linux Server Optional EUS (v. 7.6) – ppc64, ppc64le, s390x, x86_64
Red Hat Enterprise Linux for ARM and IBM Power LE (POWER9) Server (v. 7) – aarch64, noarch, ppc64le, s390x
Red Hat Enterprise Linux for ARM and IBM Power LE (POWER9) Server Optional (v. 7) – aarch64, ppc64le, s390x

3. Description:

The Berkeley Internet Name Domain (BIND) is an implementation of the Domain
Name System (DNS) protocols. BIND includes a DNS server (named); a resolver
library (routines for applications to use when interfacing with DNS); and
tools for verifying that the DNS server is operating correctly.

Security Fix(es):

* bind: BIND does not sufficiently limit the number of fetches performed
when processing referrals (CVE-2020-8616)

* bind: A logic error in code which checks TSIG validity can be used to
trigger an assertion failure in tsig.c (CVE-2020-8617)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

After installing the update, the BIND daemon (named) will be restarted
automatically.

5. Bugs fixed (https://bugzilla.redhat.com/):

1836118 – CVE-2020-8616 bind: BIND does not sufficiently limit the number of fetches performed when processing referrals
1836124 – CVE-2020-8617 bind: A logic error in code which checks TSIG validity can be used to trigger an assertion failure in tsig.c

6. Package List:

Red Hat Enterprise Linux ComputeNode EUS (v. 7.6):

Source:
bind-9.9.4-74.el7_6.4.src.rpm

noarch:
bind-license-9.9.4-74.el7_6.4.noarch.rpm

x86_64:
bind-debuginfo-9.9.4-74.el7_6.4.i686.rpm
bind-debuginfo-9.9.4-74.el7_6.4.x86_64.rpm
bind-libs-9.9.4-74.el7_6.4.i686.rpm
bind-libs-9.9.4-74.el7_6.4.x86_64.rpm
bind-libs-lite-9.9.4-74.el7_6.4.i686.rpm
bind-libs-lite-9.9.4-74.el7_6.4.x86_64.rpm
bind-utils-9.9.4-74.el7_6.4.x86_64.rpm

Red Hat Enterprise Linux ComputeNode Optional EUS (v. 7.6):

x86_64:
bind-9.9.4-74.el7_6.4.x86_64.rpm
bind-chroot-9.9.4-74.el7_6.4.x86_64.rpm
bind-debuginfo-9.9.4-74.el7_6.4.i686.rpm
bind-debuginfo-9.9.4-74.el7_6.4.x86_64.rpm
bind-devel-9.9.4-74.el7_6.4.i686.rpm
bind-devel-9.9.4-74.el7_6.4.x86_64.rpm
bind-lite-devel-9.9.4-74.el7_6.4.i686.rpm
bind-lite-devel-9.9.4-74.el7_6.4.x86_64.rpm
bind-pkcs11-9.9.4-74.el7_6.4.x86_64.rpm
bind-pkcs11-devel-9.9.4-74.el7_6.4.i686.rpm
bind-pkcs11-devel-9.9.4-74.el7_6.4.x86_64.rpm
bind-pkcs11-libs-9.9.4-74.el7_6.4.i686.rpm
bind-pkcs11-libs-9.9.4-74.el7_6.4.x86_64.rpm
bind-pkcs11-utils-9.9.4-74.el7_6.4.x86_64.rpm
bind-sdb-9.9.4-74.el7_6.4.x86_64.rpm
bind-sdb-chroot-9.9.4-74.el7_6.4.x86_64.rpm

Red Hat Enterprise Linux Server EUS (v. 7.6):

Source:
bind-9.9.4-74.el7_6.4.src.rpm

noarch:
bind-license-9.9.4-74.el7_6.4.noarch.rpm

ppc64:
bind-9.9.4-74.el7_6.4.ppc64.rpm
bind-chroot-9.9.4-74.el7_6.4.ppc64.rpm
bind-debuginfo-9.9.4-74.el7_6.4.ppc.rpm
bind-debuginfo-9.9.4-74.el7_6.4.ppc64.rpm
bind-libs-9.9.4-74.el7_6.4.ppc.rpm
bind-libs-9.9.4-74.el7_6.4.ppc64.rpm
bind-libs-lite-9.9.4-74.el7_6.4.ppc.rpm
bind-libs-lite-9.9.4-74.el7_6.4.ppc64.rpm
bind-utils-9.9.4-74.el7_6.4.ppc64.rpm

ppc64le:
bind-9.9.4-74.el7_6.4.ppc64le.rpm
bind-chroot-9.9.4-74.el7_6.4.ppc64le.rpm
bind-debuginfo-9.9.4-74.el7_6.4.ppc64le.rpm
bind-libs-9.9.4-74.el7_6.4.ppc64le.rpm
bind-libs-lite-9.9.4-74.el7_6.4.ppc64le.rpm
bind-pkcs11-9.9.4-74.el7_6.4.ppc64le.rpm
bind-pkcs11-libs-9.9.4-74.el7_6.4.ppc64le.rpm
bind-pkcs11-utils-9.9.4-74.el7_6.4.ppc64le.rpm
bind-utils-9.9.4-74.el7_6.4.ppc64le.rpm

s390x:
bind-9.9.4-74.el7_6.4.s390x.rpm
bind-chroot-9.9.4-74.el7_6.4.s390x.rpm
bind-debuginfo-9.9.4-74.el7_6.4.s390.rpm
bind-debuginfo-9.9.4-74.el7_6.4.s390x.rpm
bind-libs-9.9.4-74.el7_6.4.s390.rpm
bind-libs-9.9.4-74.el7_6.4.s390x.rpm
bind-libs-lite-9.9.4-74.el7_6.4.s390.rpm
bind-libs-lite-9.9.4-74.el7_6.4.s390x.rpm
bind-utils-9.9.4-74.el7_6.4.s390x.rpm

x86_64:
bind-9.9.4-74.el7_6.4.x86_64.rpm
bind-chroot-9.9.4-74.el7_6.4.x86_64.rpm
bind-debuginfo-9.9.4-74.el7_6.4.i686.rpm
bind-debuginfo-9.9.4-74.el7_6.4.x86_64.rpm
bind-libs-9.9.4-74.el7_6.4.i686.rpm
bind-libs-9.9.4-74.el7_6.4.x86_64.rpm
bind-libs-lite-9.9.4-74.el7_6.4.i686.rpm
bind-libs-lite-9.9.4-74.el7_6.4.x86_64.rpm
bind-pkcs11-9.9.4-74.el7_6.4.x86_64.rpm
bind-pkcs11-libs-9.9.4-74.el7_6.4.i686.rpm
bind-pkcs11-libs-9.9.4-74.el7_6.4.x86_64.rpm
bind-pkcs11-utils-9.9.4-74.el7_6.4.x86_64.rpm
bind-utils-9.9.4-74.el7_6.4.x86_64.rpm

Red Hat Enterprise Linux for ARM and IBM Power LE (POWER9) Server (v. 7):

Source:
bind-9.9.4-74.el7_6.4.src.rpm

aarch64:
bind-9.9.4-74.el7_6.4.aarch64.rpm
bind-chroot-9.9.4-74.el7_6.4.aarch64.rpm
bind-debuginfo-9.9.4-74.el7_6.4.aarch64.rpm
bind-libs-9.9.4-74.el7_6.4.aarch64.rpm
bind-libs-lite-9.9.4-74.el7_6.4.aarch64.rpm
bind-pkcs11-9.9.4-74.el7_6.4.aarch64.rpm
bind-pkcs11-libs-9.9.4-74.el7_6.4.aarch64.rpm
bind-pkcs11-utils-9.9.4-74.el7_6.4.aarch64.rpm
bind-utils-9.9.4-74.el7_6.4.aarch64.rpm

noarch:
bind-license-9.9.4-74.el7_6.4.noarch.rpm

ppc64le:
bind-9.9.4-74.el7_6.4.ppc64le.rpm
bind-chroot-9.9.4-74.el7_6.4.ppc64le.rpm
bind-debuginfo-9.9.4-74.el7_6.4.ppc64le.rpm
bind-libs-9.9.4-74.el7_6.4.ppc64le.rpm
bind-libs-lite-9.9.4-74.el7_6.4.ppc64le.rpm
bind-pkcs11-9.9.4-74.el7_6.4.ppc64le.rpm
bind-pkcs11-libs-9.9.4-74.el7_6.4.ppc64le.rpm
bind-pkcs11-utils-9.9.4-74.el7_6.4.ppc64le.rpm
bind-utils-9.9.4-74.el7_6.4.ppc64le.rpm

s390x:
bind-9.9.4-74.el7_6.4.s390x.rpm
bind-chroot-9.9.4-74.el7_6.4.s390x.rpm
bind-debuginfo-9.9.4-74.el7_6.4.s390.rpm
bind-debuginfo-9.9.4-74.el7_6.4.s390x.rpm
bind-libs-9.9.4-74.el7_6.4.s390.rpm
bind-libs-9.9.4-74.el7_6.4.s390x.rpm
bind-libs-lite-9.9.4-74.el7_6.4.s390.rpm
bind-libs-lite-9.9.4-74.el7_6.4.s390x.rpm
bind-utils-9.9.4-74.el7_6.4.s390x.rpm

Red Hat Enterprise Linux Server Optional EUS (v. 7.6):

ppc64:
bind-debuginfo-9.9.4-74.el7_6.4.ppc.rpm
bind-debuginfo-9.9.4-74.el7_6.4.ppc64.rpm
bind-devel-9.9.4-74.el7_6.4.ppc.rpm
bind-devel-9.9.4-74.el7_6.4.ppc64.rpm
bind-lite-devel-9.9.4-74.el7_6.4.ppc.rpm
bind-lite-devel-9.9.4-74.el7_6.4.ppc64.rpm
bind-pkcs11-9.9.4-74.el7_6.4.ppc64.rpm
bind-pkcs11-devel-9.9.4-74.el7_6.4.ppc.rpm
bind-pkcs11-devel-9.9.4-74.el7_6.4.ppc64.rpm
bind-pkcs11-libs-9.9.4-74.el7_6.4.ppc.rpm
bind-pkcs11-libs-9.9.4-74.el7_6.4.ppc64.rpm
bind-pkcs11-utils-9.9.4-74.el7_6.4.ppc64.rpm
bind-sdb-9.9.4-74.el7_6.4.ppc64.rpm
bind-sdb-chroot-9.9.4-74.el7_6.4.ppc64.rpm

ppc64le:
bind-debuginfo-9.9.4-74.el7_6.4.ppc64le.rpm
bind-devel-9.9.4-74.el7_6.4.ppc64le.rpm
bind-lite-devel-9.9.4-74.el7_6.4.ppc64le.rpm
bind-pkcs11-devel-9.9.4-74.el7_6.4.ppc64le.rpm
bind-sdb-9.9.4-74.el7_6.4.ppc64le.rpm
bind-sdb-chroot-9.9.4-74.el7_6.4.ppc64le.rpm

s390x:
bind-debuginfo-9.9.4-74.el7_6.4.s390.rpm
bind-debuginfo-9.9.4-74.el7_6.4.s390x.rpm
bind-devel-9.9.4-74.el7_6.4.s390.rpm
bind-devel-9.9.4-74.el7_6.4.s390x.rpm
bind-lite-devel-9.9.4-74.el7_6.4.s390.rpm
bind-lite-devel-9.9.4-74.el7_6.4.s390x.rpm
bind-pkcs11-9.9.4-74.el7_6.4.s390x.rpm
bind-pkcs11-devel-9.9.4-74.el7_6.4.s390.rpm
bind-pkcs11-devel-9.9.4-74.el7_6.4.s390x.rpm
bind-pkcs11-libs-9.9.4-74.el7_6.4.s390.rpm
bind-pkcs11-libs-9.9.4-74.el7_6.4.s390x.rpm
bind-pkcs11-utils-9.9.4-74.el7_6.4.s390x.rpm
bind-sdb-9.9.4-74.el7_6.4.s390x.rpm
bind-sdb-chroot-9.9.4-74.el7_6.4.s390x.rpm

x86_64:
bind-debuginfo-9.9.4-74.el7_6.4.i686.rpm
bind-debuginfo-9.9.4-74.el7_6.4.x86_64.rpm
bind-devel-9.9.4-74.el7_6.4.i686.rpm
bind-devel-9.9.4-74.el7_6.4.x86_64.rpm
bind-lite-devel-9.9.4-74.el7_6.4.i686.rpm
bind-lite-devel-9.9.4-74.el7_6.4.x86_64.rpm
bind-pkcs11-devel-9.9.4-74.el7_6.4.i686.rpm
bind-pkcs11-devel-9.9.4-74.el7_6.4.x86_64.rpm
bind-sdb-9.9.4-74.el7_6.4.x86_64.rpm
bind-sdb-chroot-9.9.4-74.el7_6.4.x86_64.rpm

Red Hat Enterprise Linux for ARM and IBM Power LE (POWER9) Server Optional (v. 7):

aarch64:
bind-debuginfo-9.9.4-74.el7_6.4.aarch64.rpm
bind-devel-9.9.4-74.el7_6.4.aarch64.rpm
bind-lite-devel-9.9.4-74.el7_6.4.aarch64.rpm
bind-pkcs11-devel-9.9.4-74.el7_6.4.aarch64.rpm
bind-sdb-9.9.4-74.el7_6.4.aarch64.rpm
bind-sdb-chroot-9.9.4-74.el7_6.4.aarch64.rpm

ppc64le:
bind-debuginfo-9.9.4-74.el7_6.4.ppc64le.rpm
bind-devel-9.9.4-74.el7_6.4.ppc64le.rpm
bind-lite-devel-9.9.4-74.el7_6.4.ppc64le.rpm
bind-pkcs11-devel-9.9.4-74.el7_6.4.ppc64le.rpm
bind-sdb-9.9.4-74.el7_6.4.ppc64le.rpm
bind-sdb-chroot-9.9.4-74.el7_6.4.ppc64le.rpm

s390x:
bind-debuginfo-9.9.4-74.el7_6.4.s390.rpm
bind-debuginfo-9.9.4-74.el7_6.4.s390x.rpm
bind-devel-9.9.4-74.el7_6.4.s390.rpm
bind-devel-9.9.4-74.el7_6.4.s390x.rpm
bind-lite-devel-9.9.4-74.el7_6.4.s390.rpm
bind-lite-devel-9.9.4-74.el7_6.4.s390x.rpm
bind-pkcs11-9.9.4-74.el7_6.4.s390x.rpm
bind-pkcs11-devel-9.9.4-74.el7_6.4.s390.rpm
bind-pkcs11-devel-9.9.4-74.el7_6.4.s390x.rpm
bind-pkcs11-libs-9.9.4-74.el7_6.4.s390.rpm
bind-pkcs11-libs-9.9.4-74.el7_6.4.s390x.rpm
bind-pkcs11-utils-9.9.4-74.el7_6.4.s390x.rpm
bind-sdb-9.9.4-74.el7_6.4.s390x.rpm
bind-sdb-chroot-9.9.4-74.el7_6.4.s390x.rpm

These packages are GPG signed by Red Hat for security. Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2020-8616
https://access.redhat.com/security/cve/CVE-2020-8617
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2020 Red Hat, Inc.
—–BEGIN PGP SIGNATURE—–
Version: GnuPG v1

iQIVAwUBXzvPWNzjgjWX9erEAQhQyRAAnxD9PRh6s8M0dr/s5alz3+PhYJImyu2L
ACYKqdzb3N+O9vx2CfOkOVh28o87nSE+j6T30OnV2pLtxAKppcgjY4uXT7GR9V0t
PqxHhcqN/KoEwpw+KMiVc4reaPzoZATQQqUMI5+syHRPPgYATAQD4qES5+bDgeTS
Rd9GeM82zB1lmXCP6+rzzLJKnFSmJODdYS9Clz++0oVEh9OK1P7onHp7UeWbHmeC
Ki9ChSSMSRZrSD9sGnwK6rAW3vQ/sAGwUGcQ9YaUhOilK6ZX0LTYJGLGtT3byfo4
X0IJVj3euwFmaYD9A2kRfi5FB6/gy959gLSlFsg0znCooAPXSRH6l78dNixvah9o
5WD0fgmG8uv40u+ogx7dsOf1EOSH5w/dUqEpOLx092CTsv/wYHzCODoytYiBhz43
frQlqPq71DRDLHIDBxu6w+FmjBwfgt7trBMJ8AMJcvbYgOxzDzVGtoNTlL6s2Fm2
OMbi36UrzqCPj08q0Xi2wJZZQk03n0lkLbHR93v4J6n8CdvzS953eHsQCIsGQf00
cvKa8PwneZNOlls56MmMH35aRiwxbzO1wVgcXTIDbzQJEQvylh9DMb7/hjNw4uzZ
MKDVEYCxgD9HN2EzPILKudYbR7yD6h3FyyBs4muSOgQPY2MiXbXNfApYBJH7KapV
7Ubhpgbd4Yo=
=Oe0L
—–END PGP SIGNATURE—–


RHSA-announce mailing list
[email protected]
https://www.redhat.com/mailman/listinfo/rhsa-announce

Source link

Tagged with:



Leave a Reply

Your email address will not be published. Required fields are marked *


loading...