stb Image Loader 2.23 stb_image.h stbi__tga_load memory corruption – Digitalmunition




Exploit/Advisories Cybersecurity study of the dark web exposes vulnerability to machine identities -- ScienceDaily

Published on August 15th, 2019 📆 | 2842 Views ⚑

0

stb Image Loader 2.23 stb_image.h stbi__tga_load memory corruption

CVSS Meta Temp ScoreCurrent Exploit Price (≈)
5.5$0-$5k

A vulnerability was found in stb Image Loader 2.23. It has been classified as critical. Affected is the function stbi__tga_load of the file stb_image.h. The manipulation with an unknown input leads to a memory corruption vulnerability (Heap-based). CWE is classifying the issue as CWE-122. This is going to have an impact on confidentiality, integrity, and availability.

The weakness was disclosed 08/14/2019. This vulnerability is traded as CVE-2019-15058 since 08/14/2019. Technical details are known, but there is no available exploit. The structure of the vulnerability defines a possible price range of USD $0-$5k at the moment (estimation calculated on 08/15/2019).

There is no information about possible countermeasures known. It may be suggested to replace the affected object with an alternative product.

Name

VulDB Meta Base Score: 5.5
VulDB Meta Temp Score: 5.5

VulDB Base Score: ≈5.5
VulDB Temp Score: ≈5.5
VulDB Vector: 🔒
VulDB Reliability: 🔍

VulDB Base Score: 🔒
VulDB Temp Score: 🔒
VulDB Reliability: 🔍
Class: Memory corruption / Heap-based (CWE-122)
Local: Yes
Remote: No

Availability: 🔒
Status: Not defined

Price Prediction: 🔍
Current Price Estimation: 🔒

Threat Intelligenceinfoedit

Threat: 🔍
Adversaries: 🔍
Geopolitics: 🔍
Economy: 🔍
Predictions: 🔍
Remediation: 🔍Recommended: no mitigation known

0-Day Time: 🔒

08/14/2019 Advisory disclosed
08/14/2019 +0 days CVE assigned
08/15/2019 +1 days VulDB entry created
08/15/2019 +0 days VulDB last update
CVE: CVE-2019-15058 (🔒)Created: 08/15/2019 11:27 AM
Complete: 🔍

Download the whitepaper to learn more about our service!

https://vuldb.com/?id.140082

Tagged with:



Leave a Reply