Ubuntu Security Notice USN-4724-1 ≈ Packet Storm – Digitalmunition




Exploit/Advisories no-image-featured-image.png

Published on February 8th, 2021 📆 | 7777 Views ⚑

0

Ubuntu Security Notice USN-4724-1 ≈ Packet Storm

==========================================================================
Ubuntu Security Notice USN-4724-1
February 08, 2021

openldap vulnerabilities
==========================================================================

A security issue affects these releases of Ubuntu and its derivatives:

– Ubuntu 20.10
– Ubuntu 20.04 LTS
– Ubuntu 18.04 LTS
– Ubuntu 16.04 LTS

Summary:

Several security issues were fixed in OpenLDAP.

Software Description:
– openldap: Lightweight Directory Access Protocol

Details:

It was discovered that OpenLDAP incorrectly handled Certificate Exact
Assertion processing. A remote attacker could possibly use this issue to
cause OpenLDAP to crash, resulting in a denial of service. (CVE-2020-36221)

It was discovered that OpenLDAP incorrectly handled saslAuthzTo processing.
A remote attacker could use this issue to cause OpenLDAP to crash,
resulting in a denial of service, or possibly execute arbitrary code.
(CVE-2020-36222, CVE-2020-36224, CVE-2020-36225, CVE-2020-36226)

It was discovered that OpenLDAP incorrectly handled Return Filter control
handling. A remote attacker could use this issue to cause OpenLDAP to
crash, resulting in a denial of service, or possibly execute arbitrary
code. (CVE-2020-36223)

It was discovered that OpenLDAP incorrectly handled certain cancel
operations. A remote attacker could possibly use this issue to cause
OpenLDAP to crash, resulting in a denial of service. (CVE-2020-36227)

It was discovered that OpenLDAP incorrectly handled Certificate List
Extract Assertion processing. A remote attacker could possibly use this
issue to cause OpenLDAP to crash, resulting in a denial of service.
(CVE-2020-36228)

It was discovered that OpenLDAP incorrectly handled X.509 DN parsing. A
remote attacker could possibly use this issue to cause OpenLDAP to crash,
resulting in a denial of service. (CVE-2020-36229, CVE-2020-36230)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.10:
slapd 2.4.53+dfsg-1ubuntu1.3

Ubuntu 20.04 LTS:
slapd 2.4.49+dfsg-2ubuntu1.6

Ubuntu 18.04 LTS:
slapd 2.4.45+dfsg-1ubuntu1.9

Ubuntu 16.04 LTS:
slapd 2.4.42+dfsg-2ubuntu3.12

In general, a standard system update will make all the necessary changes.

References:
https://usn.ubuntu.com/4724-1
CVE-2020-36221, CVE-2020-36222, CVE-2020-36223, CVE-2020-36224,
CVE-2020-36225, CVE-2020-36226, CVE-2020-36227, CVE-2020-36228,
CVE-2020-36229, CVE-2020-36230

Package Information:
https://launchpad.net/ubuntu/+source/openldap/2.4.53+dfsg-1ubuntu1.3
https://launchpad.net/ubuntu/+source/openldap/2.4.49+dfsg-2ubuntu1.6
https://launchpad.net/ubuntu/+source/openldap/2.4.45+dfsg-1ubuntu1.9
https://launchpad.net/ubuntu/+source/openldap/2.4.42+dfsg-2ubuntu3.12

Source link

Tagged with:



Leave a Reply