Ubuntu Security Notice USN-4886-1 ≈ Packet Storm – Digitalmunition




Exploit/Advisories no-image-featured-image.png

Published on March 23rd, 2021 📆 | 2868 Views ⚑

0

Ubuntu Security Notice USN-4886-1 ≈ Packet Storm

=========================================================================
Ubuntu Security Notice USN-4886-1
March 22, 2021

privoxy vulnerabilities
=========================================================================
A security issue affects these releases of Ubuntu and its derivatives:

– Ubuntu 20.10
– Ubuntu 20.04 LTS
– Ubuntu 18.04 LTS
– Ubuntu 16.04 LTS
– Ubuntu 14.04 ESM

Summary:

Several security issues were fixed in Privoxy.

Software Description:
– privoxy: Privacy enhancing HTTP Proxy

Details:

It was discovered that Privoxy incorrectly handled CGI requests. An attacker
could possibly use this issue to cause a denial of service or obtain sensitive
information. (CVE-2020-35502, CVE-2021-20209, CVE-2021-20210,
CVE-2021-20213, CVE-2021-20215, CVE-2021-20216, CVE-2021-20217,
CVE-2021-20272, CVE-2021-20273, CVE-2021-20275)

It was discovered that Privoxy incorrectly handled certain regular
expressions. An attacker could possibly use this issue to cause a denial of
service or obtain sensitive information. (CVE-2021-20212, CVE-2021-20276)

It was discovered that Privoxy incorrectly handled client tags. An attacker
could possibly use this issue to cause Privoxy to consume resources, resulting
in a denial of service. This issue only affected Ubuntu 18.04 LTS,
Ubuntu 20.04 LTS and Ubuntu 20.10. (CVE-2021-20211)

It was discovered that Privoxy incorrectly handled client tags. An attacker
could possibly use this issue to cause Privoxy to consume resources, resulting
in a denial of service. This issue only affected Ubuntu 20.04 LTS and
Ubuntu 20.10. (CVE-2021-20214)

Update instructions:

The problem can be corrected by updating your system to the following
package versions:

Ubuntu 20.10:
privoxy 3.0.28-3ubuntu0.1

Ubuntu 20.04 LTS:
privoxy 3.0.28-2ubuntu0.1

Ubuntu 18.04 LTS:
privoxy 3.0.26-5ubuntu0.1

Ubuntu 16.04 LTS:
privoxy 3.0.24-1ubuntu0.1

Ubuntu 14.04 ESM:
privoxy 3.0.21-7+deb8u1ubuntu0.1~esm1

In general, a standard system update will make all the necessary changes.

References:
https://ubuntu.com/security/notices/USN-4886-1
CVE-2020-35502, CVE-2021-20209, CVE-2021-20210, CVE-2021-20211,
CVE-2021-20212, CVE-2021-20213, CVE-2021-20214, CVE-2021-20215,
CVE-2021-20216, CVE-2021-20217, CVE-2021-20272, CVE-2021-20273,
CVE-2021-20275, CVE-2021-20276

Package Information:
https://launchpad.net/ubuntu/+source/privoxy/3.0.28-3ubuntu0.1
https://launchpad.net/ubuntu/+source/privoxy/3.0.28-2ubuntu0.1
https://launchpad.net/ubuntu/+source/privoxy/3.0.26-5ubuntu0.1
https://launchpad.net/ubuntu/+source/privoxy/3.0.24-1ubuntu0.1

Source link

Tagged with:



Leave a Reply